3 способа сравнения столбцов в Excel на предмет совпадений

Пользователи Excel могут вводить данные в лист различными методами. Эти методы включают ввод данных вручную, копирование из источника и вставку на лист или импорт данных с помощью Power Query. У каждого метода есть свои плюсы и минусы, причем некоторые методы помогают уменьшить количество ошибок при вводе данных лучше, чем другие.

N_Ways_to_Compare_Columns_in_Excel_for_Matches 2

Неправильный ввод данных в лист Excel может повлиять на анализ данных. Например, у вас может быть два столбца с похожими данными; однако после анализа они могут дать разные результаты. В такой ситуации Excel предлагает разные способы сравнить, совпадают ли данные в столбцах. Любопытный? Что ж, читайте дальше, чтобы узнать, как сравнивать столбцы в Excel.

Как сравнить столбцы в Excel на наличие совпадений с помощью оператора РАВНО

Это простой способ проверить, содержат ли столбцы на листе Excel одинаковые данные. Однако этот метод не учитывает регистр и фокусируется только на том, одинаковы ли текст или число в ячейках. Вот как использовать оператор EQUAL TO для сравнения столбцов в Excel на наличие совпадений:

Шаг 1. В меню «Пуск» или на панели задач вашего ПК щелкните приложение или книгу Microsoft Excel, чтобы открыть его.

Шаг 2. Поместите курсор в ячейку рядом со столбцами, которые вы хотите сравнить.

как сравнить столбцы в Excel 1как сравнить столбцы в Excel 1

Шаг 3: Введите «=» и выберите первую ячейку, которую хотите сравнить. У вас должно получиться что-то похожее на текст ниже:

=B3

как сравнить столбцы в Excel 6как сравнить столбцы в Excel 6

Шаг 4: Введите «=» еще раз и выберите вторую ячейку, которую хотите сравнить. У вас должно получиться что-то похожее на текст ниже:

=B3=C3

как сравнить столбцы в Excel 7как сравнить столбцы в Excel 7

Шаг 5. Нажмите клавишу Enter на клавиатуре, чтобы Excel вернул значение ИСТИНА или ЛОЖЬ.

как сравнить столбцы в Excel 8как сравнить столбцы в Excel 8

Шаг 6: Поместите курсор в правый нижний угол ячейки и перетащите формулу вниз, чтобы сравнить совпадения для других ячеек.

как сравнить столбцы в Excel 9как сравнить столбцы в Excel 9

Как сравнить столбцы в Excel на наличие совпадений с помощью функции ТОЧНО

Как и большинство других функций Microsoft Excel, функция ТОЧНО представляет собой заранее определенную формулу. Цель функции EXACT — проверить, являются ли две текстовые строки одинаковыми, возвращая значение TRUE или FALSE. Важно отметить, что функция EXACT чувствительна к регистру, поэтому при использовании разных регистров она вернет значение FALSE. Вот как использовать функцию ТОЧНО:

Шаг 1. В меню «Пуск» или на панели задач вашего ПК щелкните приложение или книгу Microsoft Excel, чтобы открыть его.

Шаг 2. Поместите курсор в ячейку рядом со столбцами, которые вы хотите сравнить.

как сравнить столбцы в Excel 1как сравнить столбцы в Excel 1

Шаг 3: Введите = ТОЧНО(в ячейку и нажмите клавишу TAB.

как сравнить столбцы в Excel 2как сравнить столбцы в Excel 2

Шаг 4. Выберите ячейки, которые вы хотите сравнить, и нажмите клавишу Enter, чтобы Excel вернул значение ИСТИНА или ЛОЖЬ. У вас должно получиться что-то похожее на текст ниже:

=ТОЧНО(B3:C3)

как сравнить столбцы в Excel 3как сравнить столбцы в Excel 3

Шаг 5. Поместите курсор в правый нижний угол ячейки и перетащите формулу вниз, чтобы сравнить совпадения с другими ячейками.

как сравнить столбцы в Excel 5как сравнить столбцы в Excel 5

Как сравнить столбцы в Excel на наличие совпадений, используя условие ЕСЛИ

Еще одна функция Excel, которую можно использовать для сравнения совпадений столбцов в Excel, — это функция ЕСЛИ. С помощью функции ЕСЛИ вы можете создавать условия для данных на вашем листе. Если данные в столбцах соответствуют или не соответствуют условиям, вы можете настроить их на возврат определенного результата. Вот как это сделать:

Шаг 1. В меню «Пуск» или на панели задач вашего ПК щелкните приложение или книгу Microsoft Excel, чтобы открыть его.

Шаг 2. Поместите курсор в ячейку рядом со столбцами, которые вы хотите сравнить.

как сравнить столбцы в Excel 1как сравнить столбцы в Excel 1

Шаг 3: Введите = ЕСЛИ(в ячейку и нажмите клавишу TAB.

как сравнить столбцы в Excel 10как сравнить столбцы в Excel 10

Шаг 4: Выберите первую ячейку, которую вы хотите сравнить. У вас должно получиться что-то похожее на текст ниже:

=ЕСЛИ(B3

как сравнить столбцы в Excel 11как сравнить столбцы в Excel 11

Шаг 5: Введите = после выбора первой ячейки, затем выберите вторую ячейку для сравнения. У вас должно получиться что-то похожее на текст ниже:

=ЕСЛИ(B3=C3

как сравнить столбцы в Excel 12как сравнить столбцы в Excel 12

Шаг 6. Введите результаты, которые Excel должен возвращать, если выбранные ячейки совпадают. Это называется значением, если оно истинно, и значением, если оно ложно. У вас должно получиться что-то похожее на текст ниже:

=ЕСЛИ(B3=C3, «Истина», «Ложь»)

как сравнить столбцы в Excel 13как сравнить столбцы в Excel 13

Шаг 7. Нажмите клавишу Enter на клавиатуре, чтобы Excel вернул значение ИСТИНА или ЛОЖЬ.

как сравнить столбцы в Excel 14как сравнить столбцы в Excel 14

Шаг 8. Поместите курсор в правый нижний угол ячейки и перетащите формулу вниз, чтобы сравнить совпадения для других ячеек.

как сравнить столбцы в Excel 15как сравнить столбцы в Excel 15

Поиск и удаление повторяющихся данных в Excel

При использовании Microsoft Excel могут возникнуть ситуации, когда необходимо убедиться, что данные в определенных столбцах совпадают. В других случаях вам может потребоваться убедиться, что в вашем наборе данных нет дубликатов. Используя функцию условного форматирования, вы можете выявить повторяющиеся данные в Microsoft Excel, а затем использовать кнопку «Удалить дубликаты», чтобы удалить дубликаты. В любом случае, дайте нам знать, какой прием сопоставления столбцов вы считаете наиболее полезным, в комментариях ниже.

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *