Как выбрать случайное имя из списка с помощью MS Excel

Скриншот 2014 04 21 15 09 46

Сгенерировать случайное число с помощью MS Excel очень просто. Он имеет две встроенные функции, называемые rand и ranbetween, которые помогут вам в этом.

  • rand используется для генерации числа от 0 до 1
  • randbetween генерирует целое число в заданном диапазоне

Однако задумывались ли вы когда-нибудь о выборе случайного имени или случайной строки из заданного списка? Могут быть разные сценарии, когда вам это может понадобиться. Например, редактор этого блога планирует вскоре провести розыгрыш призов. Excel может помочь ему выбрать победителей в этом случае.

Однако в Microsoft Excel нет прямой формулы для этого.

Мы изучили несколько способов, где мы можем применить некоторую логику и объединить несколько формул, чтобы выполнить задачу. И мы покажем вам два таких метода.

Полезный совет: ищете способ начать писать с новой строки в той же ячейке в MS Excel? Попробуйте клавиши Alt+Enter.

Способ 1

Шаг 1: Заполните список имен, которые у вас есть, в любом столбце, не беспокоясь о порядке. В нашем примере мы использовали столбец А. Также обратите внимание на номера первой и последней строки. Здесь они 1 и 13.

Список имен1

Шаг 2: Переключитесь на любую произвольную ячейку и введите формулу, показанную ниже.

=ДВССЫЛ(СЦЕПИТЬ(«A», СЛУЧМЕЖДУ(1, 13)))

Где,

A следует заменить столбцом, который вы использовали, и

1 и 13 следует заменить на номера первой и последней строки соответственно.

Шаг 3: Нажмите Войти и вы сможете увидеть первое случайное имя. Всякий раз, когда вы хотите новое случайное имя, просто нажмите F9.

Выбрано случайное имя1

Способ 2

Шаг 1: Заполните список имен, которые у вас есть в любом столбце, не беспокоясь о порядке.

Шаг 2: Заблокируйте область (ячейки, заполненные именами) и дайте ей имя, как показано на диаграмме ниже. Обратите внимание на поле, где я написал NameList. Это имя я присвоил списку.

Сохранить список имен1

Шаг 3: Переключитесь на любую произвольную ячейку и используйте любую из формул, показанных ниже.

=ИНДЕКС(A1:A13, СЛУЧМЕЖДУ(1, 13)) или

= ИНДЕКС (Список имен, СЛУЧМЕЖДУ (1, 13))

Где,

A следует заменить столбцом, который вы использовали

1 и 13 следует заменить на номера первой и последней строки соответственно и

NameList следует заменить именем, которое вы дали своему списку на шаге 2.

Ударять F9 всякий раз, когда вы хотите обновить случайно сгенерированное имя. Если вы хотите, чтобы два имени генерировались одновременно, напишите одну и ту же формулу в двух разных ячейках. Точно так же вы можете увеличить число до 3, 4 и так далее.

Выбрано случайное имя2

Преимущество использования последней формулы заключается в том, что ваш список и формула не обязательно должны находиться на одном листе. Это означает, что список может быть на листе 1, а формула на листе 2. Таким образом, никто не сможет увидеть, из какого списка генерируется случайное имя.

Вывод

Таким образом, вы можете выбрать одно или несколько случайных имен из списка с помощью Excel. Можете ли вы придумать какую-либо другую формулу, которая дала бы тот же результат? Если да, поделитесь с нами. Будем рады научиться.

Лучший кредит изображения: Алан Кливер

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован.